Excel: ¿Existe o no existe un dato?

Debo cargar unos datos en una columna. Pero, antes, tengo que asegurarme de que el dato no esté ya en la lista. Imagino una función a la que le paso el dato y el rango de la lista y que me diga si el dato existe o no. ¿Hay alguna función que haga algo así?
Martes, 28 de Febrero de 2017

USERS: Una hipotética función EXISTE debería tener dos argumentos:

* El rango donde existirá o no el dato buscado.

* El dato buscado propiamente dicho.

Por ejemplo, la expresión =EXISTE(A1:A10; “Juan”) nos diría si el nombre Juan está en alguna de las celdas de [A1:A10].

Podemos lograr este resultado con la función CONTAR.SI, que cuenta cuántas veces se encuentra un determinado dato dentro de un rango especificado. Por ejemplo, la expresión =CONTAR.SI(A1:A10;“Juan”) nos dice cuántas veces está el nombre Juan en el rango [A1:A10]. Si el resultado es cero, el nombre no se encuentra en el rango.

Podemos combinar esta función con una condicional que indique la situación en forma más clara: =SI(CONTAR.SI(A1:A10;“Juan”)>0; “Dato existente”;“Dato nuevo”).

Últimos lanzamientos Ver más